Lensbaby Studio Forums

 

Latest Post

11 hours ago by CatGargoyle

Re: Leaf abstractions in B&W

view post

Flash problems

Newer Topic | Older Topic

Flash problems posted by afghanimarine January 12, 2012 01:04PM reply | quote
posted by afghanimarine

I have a Nikon D80 and I cannot get the flash to work with my LB Scout. It works with my D100, but the D80 is having issues, any suggestions?
Re: Flash problems posted by maryloveslucydog January 12, 2012 08:12PM reply | quote
posted by maryloveslucydog
Did you change the flash mode setting from TTL to manual and then adjust the flash power?
Re: Flash problems posted by afghanimarine January 16, 2012 06:42AM reply | quote
posted by afghanimarine

Yes, thanks
Re: Flash problems posted by munsel October 14, 2012 03:03AM reply | quote
posted by munsel
Thank you so much, I was having the same issue and also use a D80 great ;-)
Re: Flash problems posted by Sportster77 July 27, 2013 05:18AM reply | quote
posted by Sportster77
Is there any way to use the Nikon CLS with a LB Muse? I was trying to use my Muse with a Nikon SB700 off camera.
Re: Flash problems posted by Kirsten (Admin) September 04, 2013 09:29AM reply | quote
posted by Kirsten

Hi folks,

We have a whole page on flash: [lensbaby.com]

Kirsten Hunter
Director of Customer Happiness

See more of my work on my blog:
www.livefrombeechstreet.blogspot.com

Newer Topic | Older Topic

Sorry, only registered users may post in this forum.

Click here to login

Lensbaby Newsletter - Signup Today