Lensbaby Studio Forums

 

Latest Post

19 hours ago by TG-J

Re: Lensbaby LM-10 now available

view post

Nikon D90 setting

Newer Topic | Older Topic

Nikon D90 setting posted by carlvs April 13, 2010 11:05AM reply | quote
posted by carlvs
I got my Muse yesterday.
Set my camera to manual mode as suggested in many topics here on the forum.
I can adjust my ISO and my speed settings, however I can not set my aperture. The aperture displays "F--".

Is this the normal display for the D90?

I have read to use another lens to set the aperture, shut down camera, change to the muse, and the aperture should stay at the last settings.
Is that indeed the procedure for the D90?

Thanks for the advise
Carl
Re: Nikon D90 setting posted by daftmanic April 13, 2010 03:43PM reply | quote
posted by daftmanic
Well... You set the aperture on the lens itself. With the aperture rings. The camera can't control the aperture because it's adjusted manually.

Hope that makes sense. :)
Re: Nikon D90 setting posted by n8 April 17, 2010 04:15AM reply | quote
posted by n8
What your camera is doing is normal. I haven't heard about the shut down trick, but like daftmanic said, the aperture is controlled by the ring in the lb. Since they're not cpu lenses, the camera has no idea what the f-stop is, hence the F--. You're camera is just fine (I also use a d90).
Re: Nikon D90 setting posted by lnl1003 April 19, 2010 12:04PM reply | quote
posted by lnl1003

I also use the D90 and I too get the "F--" it's normal as mentioned above. :)

Happy shooting!

composer 2.0 [larrybosworth.com]
Re: Nikon D90 setting posted by Chuck1906 July 06, 2010 08:21PM reply | quote
posted by Chuck1906
I am having a similiar problem with my D90. I cannot get my on camera flash to fire when I have the Muse and Fisheye optic attached. My flash icon flashes on the screen but will not fire. Any reason why? I did not try using my SB-600 yet.

Thanks!
Re: Nikon D90 setting posted by ranfoto July 07, 2010 02:54PM reply | quote
posted by ranfoto

You can't use the TTL mode, but look in your custom settings, there's a manual mode that will let the pop up flash at least fire ......you manually have to set the correct power.....test and yes it's a pain .

The SB-600 is much better, still not TTL, but set the sensor in the flash and it's almost automatic.

When in doubt.....it's time to read those Nikon "manuals" again !

Newer Topic | Older Topic

Sorry, only registered users may post in this forum.

Click here to login

Lensbaby Newsletter - Signup Today